Mombu the Games Forum sponsored links

Go Back   Mombu the Games Forum > Games > Role-Playing(RPG) > So... Arena and Daggerfall
User Name
Password
REGISTER NOW! Mark Forums Read

sponsored links


Reply
 
11 20th October 09:34
captain heyrab
External User
 
Posts: 1
Default So... Arena and Daggerfall


Might be something in the CMOS setup interfering with the memory space.
  Reply With Quote


  sponsored links


12 20th October 09:34
nyctolops
External User
 
Posts: 1
Default So... Arena and Daggerfall


Could be, but I don't think so. I did some more thinking about it and
I think that Arena doesn't like the complicated way that the audio
drivers are packaged. Something called ctcm.exe starts ctcu.exe which
stats vibra16.exe which defines the drivers (as far as I can tell from
the command lines). I think if I go to the vibra16 directory and find
the line which defines the drivers, I can put that into the config.sys
file directly and maybe solve the problem. I got nothing to lose but
time and everything to gain. I have been playing a bit without sound
and it's fun, but I feel like I am really missing something.
--
Nyctolops
  Reply With Quote
13 20th October 09:34
nyctolops
External User
 
Posts: 1
Default So... Arena and Daggerfall


I did some more looking and found that the real name of my sound card
is Creative SB16 PnP. The Vibra16 is just the name of the DOS sound
system. I also found that the card has three systems on it: DOS
sound, Windows sound and Windows record. Figuring that I only needed
the DOS sound part, I removed the ctcm references and loaded only the
Vibra16 parts. I found the command lines to load the DOS drivers and
added them to the config.sys. The drivers loaded successfully, though
I got a CTSOUND error. Everything else loaded, but I still got a
blank screen when Arena started. This is getting frustrating.
--
Nyctolops
  Reply With Quote
14 20th October 09:34
nyctolops
External User
 
Posts: 1
Default So... Arena and Daggerfall


I did some more checking and found that the drivers did not load
properly. I used Pause/Break to read all the stuff that usually goes
by so fast and found "Blaster environment is invalid". I have checked
and rechecked the numbers on the Blaster settings and can find no
errors. I got so frustrated I even dug out the manual, which wasn't
much help, but I did find out that the drivers I was trying to load
weren't intended to be used alone. They are called low level drivers
and are supposed to be used in conjunction with the high level drivers
in the ctcm directory. I think I'll make a very simple boot disk that
only loads the very basics to play silent with and keep trying
whatever I can think of to make the sound work. Any suggestions would
be welcome.
--
Nyctolops
  Reply With Quote
15 20th October 09:34
nesstar
External User
 
Posts: 1
Default So... Arena and Daggerfall


My suggestion: Keep the reference to CTCM.EXE, but remove all else.

Also, on my PC my DOS configure has a SET BLASTER= line that defines
the environment (SET BLASTER=A220 I5 D1 T5 etc...) Keep that as well
if you have such a line.

Then again, the DOS that comes with Win98 may not work the same as DOS
6.22. I know that with my PC all I need is for my Autoexec.bat to
contain LH=C:\DOS\CTCM.EXE and the SET BLASTER line and I'm all set.
  Reply With Quote
16 20th October 09:35
nyctolops
External User
 
Posts: 1
Default So... Arena and Daggerfall


I believe that the Win98 DOS version is 7.0, but the basics may not
have changed all that much. Thank you for your suggestion. I will
try it tonight and let you know what happens.
--
Nyctolops
  Reply With Quote
17 20th October 09:35
nyctolops
External User
 
Posts: 1
Default So... Arena and Daggerfall


I tried your version and several variations on it, as DOS 6.22 needs
SET SOUND and SET MIDI lines for the sound to work. It either skips
the sound system altogether, as when I took out the DEVICEHIGH
C:\CTCM\CTCM.EXE line from the config.sys file, or it hangs. The most
common problem is when I start from the boot card, I see all the usual
startup messages up to the point where the sound card is identified,
then the system just hangs at that line and won't go any farther, no
matter how long I wait.

On the other hand, I made a very simple boot disk that doesn't
reference the sound card at all and have been playing in silent mode.
My character managed to get out of the sewers and into town and he has
been running errands and has made one dungeon trip so far. One thing
that puzzles me is that two NPCs have said that they marked the Castle
for me on my map, but no Castle ID shows up. One question: on the
Continental Map, what is the first symbol for? I know that the horse
is fast travel, as I used it to get back to town from my dungeon
crawl, but I don't know what the first one is.
--
Nyctolops
  Reply With Quote
18 20th October 09:35
xocyll
External User
 
Posts: 1
Default So... Arena and Daggerfall


Nyctolops <nyctolops@vla.nospam.com> looked up from reading the entrails
of the **** spammer to utter "The Augury is good, the signs say:


From the game's point of view there's no difference between 6.22 and 7.0.

A distant memory asks is there a file called Diagnose.exe?
If so, run it before playing the game (or picking the sound option in
Arena.).

I distantly recall that some of the early plug and play, no-jumper,
really-designed-just-for-windows cards had to be woken up in Dos and
that's the program that tests it and wakes it up.


Which castle?

If I remember correctly Arena had two methods of fast travel - safe and
risky; Safe stays in Inns at night (and costs money), Risky camps out
and is free, but carries the risk of being attacked during the journey.

Xocyll
--
I don't particularly want you to FOAD, myself. You'll be more of
a cautionary example if you'll FO And Get Chronically, Incurably,
Painfully, Progressively, Expensively, Debilitatingly Ill. So
FOAGCIPPEDI. -- Mike Andrews responding to an idiot in asr
  Reply With Quote
19 20th October 09:35
nesstar
External User
 
Posts: 1
Default So... Arena and Daggerfall


I believe the first icon is a location lookup, but I could be
misremembering. There's only one mode of Fast Travel though.

Now as for the castle, it's gonna be one of the castle icons on your
fast-travel map IIRC. Run your mouse all over them and see their
names. Also, just because they marked it may not necessarily mean its
within your current province.
  Reply With Quote
20 20th October 09:35
nyctolops
External User
 
Posts: 1
Default So... Arena and Daggerfall


There is a command C:\VIBRA16\DIAGNOSE /S which is the first thing
after the SET commands in the autoexec.bat. I have included it as one
of the LH commands. I'll look to see if there is DIAGNOSE.EXE. If
there is I will load it as a DEVICEHIGH in the config.sys.


From the directions in the manual, I get the impression that this card
was designed for Win95, but would work with DOS and Win3.1.


The one in Rock Springs, which is where Maldrin found himself after he
escaped from the sewers.


I guess I have nothing to lose by just clicking on the icon after
saving to see what it does. I can't make out what the icon is, or I
might be able to guess at it.
--
Nyctolops
  Reply With Quote
Reply


Thread Tools
Display Modes




Copyright 2006 SmartyDevil.com - Dies Mies Jeschet Boenedoesef Douvema Enitemaus -
666