Mombu the GNU Linux Forum sponsored links

Go Back   Mombu the GNU Linux Forum > GNU_Linux > Integrated Broadcom nic on Dell times out with dhcp
User Name
Password
REGISTER NOW! Mark Forums Read

sponsored links


Reply
 
1 2nd May 04:15
kent west
External User
 
Posts: 1
Default Integrated Broadcom nic on Dell times out with dhcp


I have a new Dell Dimension 2400 with an integrated Broadcom BCM4401
100Base-T nic.

When I first installed Woody on it, with a 2.4.18-bf kernel, the nic was
not recognized.

When I upgraded the kernel to a stock 2.4.22-1-686 kernel, the nic
worked. Later, for other reasons, I needed to compile my own kernel. I
copied over the .config file and recompiled a new 2.4.22 kernel. The nic
stopped getting a dhcp address, and if I put in a static address, the
network was unreachable.

So I changed back to the stock kernel, and the problem remained.

After a while I discovered that if I power off the computer and unplug
it from the AC mains for a few seconds, I can then restart the machine
and get a DHCP address, but the network remains broken with errors such as:
b44: eth0: Link is down
b44: eth0: Link is up at 10 Mbps, half duplex.
b44: eth0: Flow control is off for TX and off for RX.

and then the network traffic just dies. A ping just sits there until I
ctrl-c it, at which time I don't even get the normal x % packets lost
type messages.

If I reconfigure the nic for static and restart the network (but not the
computer), the network remains dead. I can then reconfigure for dhcp,
and restart the network, and never get a new dchp address. It's like the
nic has gone off to spend the weekend in the Bahamas.

If I reconfigure the nic for static and then restart the whole computer
(with a power off), the network comes back up and I can use the machine,
as long as I don't stop the network for any reason. If I do stop the
network, the nic goes back on vacation until the next power cycling.

It "feels" like the driver is failing to reset something in the nic, or
the nic is failing to accept a reset command, but not being a
programmer, that's just shooting from the hip.

I installed the nictools-pci package, but don't find anything of use for
the Broadcom. I also installed mii-diag, but it reports that everything
is dandy:

Using the default interface 'eth0'.
Basic registers of MII PHY #1: 1000 782d 0040 6360 0de1 0021 0004 2001.
Basic mode control register 0x1000: Auto-negotiation enabled.
You have link beat, and everything is working OK.
Your link partner is generating 10baseT link beat (no autonegotiation).
End of basic transceiver information.

Any clues would be appreciated.

--
Kent

--
Kent West (westk@acu.edu)


--
To UNSUBSCRIBE, email to debian-user-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
  Reply With Quote


  sponsored links


2 2nd May 14:10
harlan
External User
 
Posts: 1
Default Integrated Broadcom nic on Dell times out with dhcp


[...]


Have you tried using mii-tool to set speed and duplex, rather than
letting it get auto-negotiated? The description above says "(no
autonegotiation)" but you've got auto-negotiation enabled for the
card.

Some device/card combos work well with auto-negotiation enabled, and
others work horribly. Maybe setting it yourself would help. (Which
to set it to is probably a matter of trial and error; there are only
four combos.)

HTH,

--
Pete Harlan
harlan@artselect.com


--
To UNSUBSCRIBE, email to debian-user-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
  Reply With Quote
3 2nd May 14:11
clive menzies
External User
 
Posts: 1
Default Integrated Broadcom nic on Dell times out with dhcp


Hi Kent

I had similar problems with epro100.c (driver) card which came with the
HP server I recently acquired. It just seemed to drop connections for no
apparent reason. Being less tenacious (or less capable) I just swapped
the card for a 3com905 which I had used before and never had a problem
since. I know it's a cop out but with so many things to get right... it
was one less.

I suspect you will get to the bottom of it

Regards

Clive

--
http://www.clivemenzies.co.uk
strategies for business


--
To UNSUBSCRIBE, email to debian-user-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
  Reply With Quote
4 3rd May 20:34
kent west
External User
 
Posts: 1
Default Integrated Broadcom nic on Dell times out with dhcp


# mii-tool
SIOCGMIIPHY on 'eth0' failed: Operation not supported
no MII interfaces found

# mii-diag
Using the default interface 'eth0'.
Basic registers of MII PHY #1: 1000 782d 0040 6360 0de1 0021 0004 2001.
Basic mode control register 0x1000: Auto-negotiation enabled.
You have link beat, and everything is working OK.
Your link partner is generating 10baseT link beat (no autonegotiation).
End of basic transceiver information.


--

Kent West (westk@acu.edu)


--
To UNSUBSCRIBE, email to debian-user-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
  Reply With Quote
5 6th May 07:26
rohit kumar mehta
External User
 
Posts: 1
Default forcing a popup to KDE and GNOME users


Hi, I would like to force a Java popup window to all users who start an
Xsession on our Debian boxes.
We currently have kde and gnome installed, and neither of them seem to
run commands from /etc/X11/xinit/xinitrc (even when the user does not
have a .xinitrc). I am having some small success
modifying the /etc/gnome/default.session, but if the user has ever
logged into gnome, there will be
a ~/.gnome directory and it will not use this information.

Can anyone suggest a better way to make this popup appear? We just want
to give our users some information with the Windowmanager splash.

Thanks,

Rohit


--
To UNSUBSCRIBE, email to debian-user-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
  Reply With Quote
6 6th May 17:17
rohit kumar mehta
External User
 
Posts: 1
Default forcing a popup to KDE and GNOME users


Hah! I have found the answer in modifying the scripts in
/etc/gdm/Sessions

--
To UNSUBSCRIBE, email to debian-user-request@lists.debian.org
with a subject of "unsubscribe". Trouble? Contact listmaster@lists.debian.org
  Reply With Quote
7 23rd May 07:59
karsten m. self
External User
 
Posts: 1
Default Integrated Broadcom nic on Dell times out with dhcp


Last I played with one of these was November, 2002. No support except
in experimental at the time. Broadcom's somewhat poor about providing
specs and/or support, and is among the NIC vendors who've had
comprehension difficulties regarding obligations attending use of GPL'd
software (http://www.dslreports.com/shownews/35103).

Peace. --
Karsten M. Self <kmself@ix.netcom.com> http://kmself.home.netcom.com/
What Part of "Gestalt" don't you understand?
There is no K5 Cabal: http://www.kuro5hin.org/

-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.3 (GNU/Linux)

iD8DBQE/xvgyefG8443k044RAo6AAJ4uDMJOQJ5LJrVHLsgjPBiOiNH5sQ CfXD2t
whHZGMHwTRmhrVYRjRLyR/4=
=zqTD
-----END PGP SIGNATURE-----
  Reply With Quote
Reply


Thread Tools
Display Modes




Copyright 2006 SmartyDevil.com - Dies Mies Jeschet Boenedoesef Douvema Enitemaus -
666