Mombu the GNU Linux Forum sponsored links

Go Back   Mombu the GNU Linux Forum > GNU_Linux > Advanced depend atoms
User Name
Password
REGISTER NOW! Mark Forums Read

sponsored links


Reply
 
1 4th March 03:17
gard spreemann
External User
 
Posts: 1
Default Advanced depend atoms


How would I formulate a depend atom saying:
"(>=foo/bar-1.0.4) AND (NOT foo/bar-1.1*)"
or in other words
"foo/bar of version 1.0.4 or higher, but not a version of the 1.1.x series".
Alternatively a way of saying "foo/bar of series 1.0.x where x is at least 4"
would work too.
If it's in the docs, please f****ve me, but I just don't see it...

--
gentoo-user@gentoo.org mailing list
  Reply With Quote


  sponsored links


2 4th March 13:41
yi ding
External User
 
Posts: 1
Default Advanced depend atoms


Have you tried using a wildcard, like foo/bar-1.0.*?

Yi

--
gentoo-user@gentoo.org mailing list
  Reply With Quote
3 5th March 03:09
gard spreemann
External User
 
Posts: 1
Default Advanced depend atoms


That will give me the "is in 1.0.x series" requirement, yes. But how do I
ensure that x (* in the atom) is at least 4?

--
gentoo-user@gentoo.org mailing list
  Reply With Quote
4 5th March 03:09
jason stubbs
External User
 
Posts: 1
Default Advanced depend atoms


It's not supported just yet. It will probably be introduced in portage-2.0.52.
Syntax will either be "&& ( >=foo/bar-1.0.4 <foo/bar-1.1 )" or plain old
">=foo/bar-1.0.4 <foo/bar-1.1" - I prefer using the latter.

Regards,
Jason Stubbs

--
gentoo-user@gentoo.org mailing list
  Reply With Quote
5 5th March 03:10
gard spreemann
External User
 
Posts: 1
Default Advanced depend atoms


Hmm. How would I implement such a dependency in an ebuild at the present then?

--
gentoo-user@gentoo.org mailing list
  Reply With Quote
6 5th March 03:10
jason stubbs
External User
 
Posts: 1
Default Advanced depend atoms


Well, I'm not certain as to what is actually done at present. I would suggest
to just use =foo/bar-1.0* and add something similar to the following in pkg_setup():
has_version '>=foo/bar-1.0.4' || die "foo/bar-1.0.4 or later is required"

Regards,
Jason Stubbs

--
gentoo-user@gentoo.org mailing list
  Reply With Quote
7 5th March 03:11
gard spreemann
External User
 
Posts: 1
Default Advanced depend atoms


Good idea, thanks.

--
gentoo-user@gentoo.org mailing list
  Reply With Quote
Reply


Thread Tools
Display Modes




Copyright 2006 SmartyDevil.com - Dies Mies Jeschet Boenedoesef Douvema Enitemaus -
666