Mombu the GNU Linux Forum sponsored links

Go Back   Mombu the GNU Linux Forum > GNU_Linux > udev is renaming my ethernet devices. make it stop!
User Name
Password
REGISTER NOW! Mark Forums Read

sponsored links


Reply
 
1 20th September 03:47
az nomad
External User
 
Posts: 1
Default udev is renaming my ethernet devices. make it stop!


Udev has a nasty habit where it takes it upon itself to rename
ethernet devices.
I have lines in demsg such as:
udev: renamed network interface eth1 to eth2
udev: renamed network interface eth0_rename to eth1

This behavior ****s especially when udev changes its mind between
reboots where NO hardware changes have occured. My motherboard
ethernet which has been eth0 for *years*, is now getting renamed to
eth2.

I see rules in /etc/udev/rules.d/70-persistent-net.rules and when I had
swapped out a plugin card and udev started it's musical chairs game, I
was able to reverse it by deleting the extranious rules there.

However, it won't leave my motherboard at eth0. I delete the rule,
and some nanny process shoves it back giving me two rules for the
motherboard ethernet.

I don't really care what the ethernet devices get named as long as they
don't change for no damn reason between reboots. This system is a
mythtv server and I don't appreciate having to get out a keyboard to
fix something that was previously working. If it works, don't fix it!
  Reply With Quote


  sponsored links


2 20th September 03:47
j.o. aho
External User
 
Posts: 1
Default udev is renaming my ethernet devices. make it stop!


The udev rule is set by MAC-address, if you change MAC-address, a new rule is
setup and the ethernet device gets a new name. The system will not remove a
device that "disappeared".

This rule is there to ensure that you get the same device name each time,
regardless which version of the kernel you run, regardless if you build in the
driver or use a module, as there are people who don't like switching the
network cable when the devices changes names.

Are you sure your hardware isn't broke?

--

//Aho
  Reply With Quote
3 20th September 03:47
michał górny
External User
 
Posts: 1
Default udev is renaming my ethernet devices. make it stop!


Instead of removing the rules, change the device names there. Else, udev
will detect that device ain't listed and dump its data again.

--
Best regards, Michał Górny
<http://mailnull.com/w?au=f6744c6f5e097cc9816a562802f331c2>
<xmpp:mgorny@jabster.pl>
  Reply With Quote
4 20th September 03:47
az nomad
External User
 
Posts: 1
Default udev is renaming my ethernet devices. make it stop!


The device was already listed. The nanny process would come and add an
additional rule for the same mac address, override it, and get it renamed
to eth2.
  Reply With Quote
5 20th September 21:46
mike bleiweiss
External User
 
Posts: 1
Default udev is renaming my ethernet devices. make it stop!


I've had this same problem with some nvidia chipsets (nforce, etc). You
may notice that your MAC address is changing every time the computer is
rebooted. It's the BIOS that is doing this. The kernel boots up, udev
sees the nic as a different device since it has a different MAC, and then
it assigns the "new device" as a different /dev/eth*.

You may find a setting in the BIOS which disables this - but it's never
worked for me. I eventually ended up replacing the motherboard. I did
have a script going for a while that would change the device back after
boot, but it caused all kinds of occasional random wierdness.

You may be able to modify your /etc/udev/rules.d/70-persistent-net.rules
and change the eth* lines to eth0.

Some similar references:
http://www.linuxquestions.org/questions/linux-hardware-18/nvidia-nforce-
network-adapter-has-different-mac-adress-every-boot-569576/

http://ubuntuforums.org/archive/index.php/t-593747.html
  Reply With Quote
Reply


Thread Tools
Display Modes




Copyright 2006 SmartyDevil.com - Dies Mies Jeschet Boenedoesef Douvema Enitemaus -
666