Mombu the Microsoft Forum sponsored links

Go Back   Mombu the Microsoft Forum > Microsoft > BAM EventBus Service (event id:16)
User Name
Password
REGISTER NOW! Mark Forums Read

sponsored links


Reply
 
1 7th May 12:34
nessuno
External User
 
Posts: 1
Default BAM EventBus Service (event id:16)


I've got a request-response inbound port with an MLLP location so that
I can receive HL7 messages and reply with an ACK.

Until a couple of hours ago everything was running fine, but now
biztalk replies with an ACK only to the first message sent, refusing to
send ACKs to subsequent messages until I break and re-establish the
connection.

Needless to say, having the lab system connect, send the message and
disconnect is not an option

Here's what keeps being logged in the application log:

----------------
Unhandled exception caught, exception details:
System.NullReferenceException: Object reference not set to an instance
of an object.
at
Microsoft.Solutions.BTAHL7.MLLP.ReceiveSession.Asy ncSender_SendCompleted(Object
sender, SendCompletionEventArgs status)
at
Microsoft.Solutions.BTAHL7.MLLP.AsyncStreamSender. WriteCallback(Object
state, Boolean timeout).
------------

It looks like something bad happens after the first ACK is sent, but
frankly I've no idea on how to troubleshoot this...

Any help is greatly appreciated

Luca
  Reply With Quote


  sponsored links


2 7th May 12:34
keithlim2020
External User
 
Posts: 1
Default BAM EventBus Service (event id:16)


Hi Luca,

Not sure how this relates to the subject header above? Wrong title?
RE: BAM EventBus Service (event id:16)

Please clarify or create a new message with the appropriate subject.

Thanks,
Keith Lim [MSFT]

--------------------
From: "nessuno" <nessuno@operamail.com>
Newsgroups: microsoft.public.biztalk.accelerator.hl7
Subject: BAM EventBus Service (event id:16)
Date: 11 Feb 2006 09:22:27 -0800
Organization: http://groups.google.com
Lines: 32
Message-ID: <1139678547.656914.8550@g14g2000cwa.googlegroups.c om>
NNTP-Posting-Host: 87.6.169.152
Mime-Version: 1.0
Content-Type: text/plain; charset="iso-8859-1"
X-Trace: posting.google.com 1139678552 20542 127.0.0.1 (11 Feb 2006
17:22:32 GMT)
X-Complaints-To: groups-abuse@google.com
NNTP-Posting-Date: Sat, 11 Feb 2006 17:22:32 +0000 (UTC)
User-Agent: G2/0.2
X-HTTP-UserAgent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US;
rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1,gzip(gfe),gzip(gfe)
Complaints-To: groups-abuse@google.com
Injection-Info: g14g2000cwa.googlegroups.com; posting-host=87.6.169.152;
posting-account=h74yGwwAAACNMftiVghM73CKzPUdBif_
Path:
TK2MSFTNGXA01.phx.gbl!TK2MSFTNGP08.phx.gbl!newsfee d00.sul.t-online.de!t-onli
ne.de!news.glorb.com!postnews.google.com!g14g2000c wa.googlegroups.com!not-fo
r-mail
Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.biztalk.accelerator.hl7:1332
X-Tomcat-NG: microsoft.public.biztalk.accelerator.hl7

I've got a request-response inbound port with an MLLP location so that
I can receive HL7 messages and reply with an ACK.

Until a couple of hours ago everything was running fine, but now
biztalk replies with an ACK only to the first message sent, refusing to
send ACKs to subsequent messages until I break and re-establish the
connection.

Needless to say, having the lab system connect, send the message and
disconnect is not an option

Here's what keeps being logged in the application log:

----------------
Unhandled exception caught, exception details:
System.NullReferenceException: Object reference not set to an instance
of an object.
at
Microsoft.Solutions.BTAHL7.MLLP.ReceiveSession.Asy ncSender_SendCompleted(Obj
ect
sender, SendCompletionEventArgs status)
at
Microsoft.Solutions.BTAHL7.MLLP.AsyncStreamSender. WriteCallback(Object
state, Boolean timeout).
------------

It looks like something bad happens after the first ACK is sent, but
frankly I've no idea on how to troubleshoot this...

Any help is greatly appreciated

Luca

Thanks,
Keith Lim [MSFT]
My BizTalk BAM Blog: http://blogs.msdn.com/keithlim/default.aspx
--

This posting is provided "AS IS" with no warranties, and confers no rights.
Use of included script samples are subject to the terms specified at
http://www.microsoft.com/info/cpyright.htm

Note: For the benefit of the community-at-large, all responses to this
message are best directed to the newsgroup/thread from which they
originated.
  Reply With Quote
3 7th May 12:34
nessuno ޲˧جr,+&
External User
 
Posts: 1
Default BAM EventBus Service (event id:16)


Keith,

the title contains the source (BAM EventBus Service) and the event id (16)
of the messages I keep finding. The description is included in the body of my
message:

----------------
Unhandled exception caught, exception details:
System.NullReferenceException: Object reference not set to an instance
of an object.
at
Microsoft.Solutions.BTAHL7.MLLP.ReceiveSession.Asy ncSender_SendCompleted(Object
sender, SendCompletionEventArgs status)
at
Microsoft.Solutions.BTAHL7.MLLP.AsyncStreamSender. WriteCallback(Object
state, Boolean timeout).
------------

To further explain the problem: this gets logged everytime I receive an HL7
message on a request-response inbound port and reply back with an ACK.
subsequent messages simply "disappear". I see them coming using tcpdump, but
they are no longer processed by the MLLP adapter. If I close and reopen the
port (from the ancillary system or restarting biztalk) I get another message,
send another ack and the above gets logged.

Thanks

Luca
  Reply With Quote
4 7th May 12:34
keithlim2020
External User
 
Posts: 1
Default BAM EventBus Service (event id:16)


Hi Luca,

Could you explain your scenario and what kind of BAM setup you have. Do
you have any BAM Activity definition deployed, TPE tracking profile
deployed?

Thanks,
Keith
--------------------
Thread-Topic: BAM EventBus Service (event id:16)
thread-index: AcYxNbugF1MR44ztTACYkGs1qGInSw==
X-WBNR-Posting-Host: 87.7.169.218
From: "=?Utf-8?B?bmVzc3Vubw==?=" <nessuno@discussions.microsoft.com>
References: <1139678547.656914.8550@g14g2000cwa.googlegroups.c om>
<WeYDZENMGHA.668@TK2MSFTNGXA01.phx.gbl>
Subject: RE: BAM EventBus Service (event id:16)
Date: Mon, 13 Feb 2006 23:10:27 -0800
Lines: 116
Message-ID: <63FB2713-2062-4655-87F8-206492597E58@microsoft.com>
MIME-Version: 1.0
Content-Type: text/plain;
charset="Utf-8"
Content-Transfer-Encoding: 7bit
X-Newsreader: Microsoft CDO for Windows 2000
Content-Class: urn:content-classes:message
Importance: normal
Priority: normal
X-MimeOLE: Produced By Microsoft MimeOLE V6.00.3790.0
Newsgroups: microsoft.public.biztalk.accelerator.hl7
NNTP-Posting-Host: TK2MSFTNGXA03.phx.gbl 10.40.2.250
Path: TK2MSFTNGXA01.phx.gbl!TK2MSFTNGXA03.phx.gbl
Xref: TK2MSFTNGXA01.phx.gbl microsoft.public.biztalk.accelerator.hl7:1336
X-Tomcat-NG: microsoft.public.biztalk.accelerator.hl7

Keith,

the title contains the source (BAM EventBus Service) and the event id
(16)
of the messages I keep finding. The description is included in the body of
my
message:

----------------
Unhandled exception caught, exception details:
System.NullReferenceException: Object reference not set to an instance
of an object.
at
Microsoft.Solutions.BTAHL7.MLLP.ReceiveSession.Asy ncSender_SendCompleted(Obj
ect
sender, SendCompletionEventArgs status)
at
Microsoft.Solutions.BTAHL7.MLLP.AsyncStreamSender. WriteCallback(Object
state, Boolean timeout).
------------

To further explain the problem: this gets logged everytime I receive an HL7
message on a request-response inbound port and reply back with an ACK.
subsequent messages simply "disappear". I see them coming using tcpdump,
but
they are no longer processed by the MLLP adapter. If I close and reopen the
port (from the ancillary system or restarting biztalk) I get another
message,
send another ack and the above gets logged.

Thanks

Luca


Thanks,
Keith Lim [MSFT]
My BizTalk BAM Blog: http://blogs.msdn.com/keithlim/default.aspx
--

This posting is provided "AS IS" with no warranties, and confers no rights.
Use of included script samples are subject to the terms specified at
http://www.microsoft.com/info/cpyright.htm

Note: For the benefit of the community-at-large, all responses to this
message are best directed to the newsgroup/thread from which they
originated.
  Reply With Quote
Reply


Thread Tools
Display Modes




Copyright 2006 SmartyDevil.com - Dies Mies Jeschet Boenedoesef Douvema Enitemaus -
666