Mombu the Php Forum sponsored links

Go Back   Mombu the Php Forum > Php > #37411 : fopen fails after 2200 VHOST entries
User Name
Password
REGISTER NOW! Mark Forums Read

sponsored links


Reply
 
1 2nd June 11:15
php-bugs
External User
 
Posts: 1
Default #37411 : fopen fails after 2200 VHOST entries


From: phpbugs at pureplan dot com
Operating system: FreeBSD 5.3-RELEASE
PHP version: 4.4.2
PHP Bug Type: *URL Functions
Bug description: fopen fails after 2200 VHOST entries

Description:
------------
Pretty simple, fopen works great until with 2,199 vhosts in Apache, but as
soon as we add that last one 2,200 fopen will not work anymore. I am not
sure if it is server related, Apache related or PHP related but I would
really like to know how to fix it.

; PHP INI FILE IS SET TO ON
allow_url_fopen = On

Reproduce code:
---------------
Setup a Apache server with 2,199 VHOST entries, test fopen, works great.
Add one more entry at the bottom of your VHOST file and test fopen again.

To be more specific fopen FAILS only if you try opening with
http://page... or ftp://.... you can still use a local path
"/usr/local/apache/vhosts/website.com/".

Expected result:
----------------
FOPEN should work with 10,000 VHOSTS if not more.

Actual result:
--------------
when fopen starts to run the whole page comes out blank right at the fopen
command.

--
Edit bug report at http://bugs.php.net/?id=37411&edit=1
--
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=37411&r=trysnapshot44
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=37411&r=trysnapshot52
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=37411&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=37411&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=37411&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=37411&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=37411&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=37411&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=37411&r=support
Expected behavior: http://bugs.php.net/fix.php?id=37411&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=37411&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=37411&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=37411&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=37411&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=37411&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=37411&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=37411&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=37411&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=37411&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=37411&r=mysqlcfg
  Reply With Quote


  sponsored links


2 2nd June 11:16
External User
 
Posts: 1
Default #37411 : fopen fails after 2200 VHOST entries


ID: 37411
Updated by: tony2001@php.net
Reported By: phpbugs at pureplan dot com
-Status: Open
+Status: Bogus
Bug Type: *URL Functions
Operating System: FreeBSD 5.3-RELEASE
PHP Version: 4.4.2
New Comment:

If you try to search the bug DB you can find at least 20 reports about
it.
It's fixed in CVS. Long time ago.
You have to wait for the next 4.4.x release or (I'd recommend that)
upgrade to 5.1.


Previous Comments:
------------------------------------------------------------------------

[2006-05-11 18:39:30] phpbugs at pureplan dot com

Description:
------------
Pretty simple, fopen works great until with 2,199 vhosts in Apache, but
as soon as we add that last one 2,200 fopen will not work anymore. I am
not sure if it is server related, Apache related or PHP related but I
would really like to know how to fix it.

; PHP INI FILE IS SET TO ON
allow_url_fopen = On

Reproduce code:
---------------
Setup a Apache server with 2,199 VHOST entries, test fopen, works
great. Add one more entry at the bottom of your VHOST file and test
fopen again.

To be more specific fopen FAILS only if you try opening with
http://page... or ftp://.... you can still use a local path
"/usr/local/apache/vhosts/website.com/".

Expected result:
----------------
FOPEN should work with 10,000 VHOSTS if not more.

Actual result:
--------------
when fopen starts to run the whole page comes out blank right at the
fopen command.


------------------------------------------------------------------------


--
Edit this bug report at http://bugs.php.net/?id=37411&edit=1
  Reply With Quote
3 2nd June 11:16
php-bugs
External User
 
Posts: 1
Default #37411 : fopen fails after 2200 VHOST entries


From: phpbugs at pureplan dot com
Operating system: FreeBSD 5.3-RELEASE
PHP version: 4.4.2
PHP Bug Type: *URL Functions
Bug description: fopen fails after 2200 VHOST entries

Description:
------------
Pretty simple, fopen works great until with 2,199 vhosts in Apache, but as
soon as we add that last one 2,200 fopen will not work anymore. I am not
sure if it is server related, Apache related or PHP related but I would
really like to know how to fix it.

; PHP INI FILE IS SET TO ON
allow_url_fopen = On

Reproduce code:
---------------
Setup a Apache server with 2,199 VHOST entries, test fopen, works great.
Add one more entry at the bottom of your VHOST file and test fopen again.

To be more specific fopen FAILS only if you try opening with
http://page... or ftp://.... you can still use a local path
"/usr/local/apache/vhosts/website.com/".

Expected result:
----------------
FOPEN should work with 10,000 VHOSTS if not more.

Actual result:
--------------
when fopen starts to run the whole page comes out blank right at the fopen
command.

--
Edit bug report at http://bugs.php.net/?id=37411&edit=1
--
Try a CVS snapshot (PHP 4.4): http://bugs.php.net/fix.php?id=37411&r=trysnapshot44
Try a CVS snapshot (PHP 5.2): http://bugs.php.net/fix.php?id=37411&r=trysnapshot52
Try a CVS snapshot (PHP 6.0): http://bugs.php.net/fix.php?id=37411&r=trysnapshot60
Fixed in CVS: http://bugs.php.net/fix.php?id=37411&r=fixedcvs
Fixed in release: http://bugs.php.net/fix.php?id=37411&r=alreadyfixed
Need backtrace: http://bugs.php.net/fix.php?id=37411&r=needtrace
Need Reproduce Script: http://bugs.php.net/fix.php?id=37411&r=needscript
Try newer version: http://bugs.php.net/fix.php?id=37411&r=oldversion
Not developer issue: http://bugs.php.net/fix.php?id=37411&r=support
Expected behavior: http://bugs.php.net/fix.php?id=37411&r=notwrong
Not enough info: http://bugs.php.net/fix.php?id=37411&r=notenoughinfo
Submitted twice: http://bugs.php.net/fix.php?id=37411&r=submittedtwice
register_globals: http://bugs.php.net/fix.php?id=37411&r=globals
PHP 3 support discontinued: http://bugs.php.net/fix.php?id=37411&r=php3
Daylight Savings: http://bugs.php.net/fix.php?id=37411&r=dst
IIS Stability: http://bugs.php.net/fix.php?id=37411&r=isapi
Install GNU Sed: http://bugs.php.net/fix.php?id=37411&r=gnused
Floating point limitations: http://bugs.php.net/fix.php?id=37411&r=float
No Zend Extensions: http://bugs.php.net/fix.php?id=37411&r=nozend
MySQL Configuration Error: http://bugs.php.net/fix.php?id=37411&r=mysqlcfg
  Reply With Quote
4 2nd June 11:16
External User
 
Posts: 1
Default #37411 : fopen fails after 2200 VHOST entries


ID: 37411
Updated by: tony2001@php.net
Reported By: phpbugs at pureplan dot com
-Status: Open
+Status: Bogus
Bug Type: *URL Functions
Operating System: FreeBSD 5.3-RELEASE
PHP Version: 4.4.2
New Comment:

If you try to search the bug DB you can find at least 20 reports about
it.
It's fixed in CVS. Long time ago.
You have to wait for the next 4.4.x release or (I'd recommend that)
upgrade to 5.1.


Previous Comments:
------------------------------------------------------------------------

[2006-05-11 18:39:30] phpbugs at pureplan dot com

Description:
------------
Pretty simple, fopen works great until with 2,199 vhosts in Apache, but
as soon as we add that last one 2,200 fopen will not work anymore. I am
not sure if it is server related, Apache related or PHP related but I
would really like to know how to fix it.

; PHP INI FILE IS SET TO ON
allow_url_fopen = On

Reproduce code:
---------------
Setup a Apache server with 2,199 VHOST entries, test fopen, works
great. Add one more entry at the bottom of your VHOST file and test
fopen again.

To be more specific fopen FAILS only if you try opening with
http://page... or ftp://.... you can still use a local path
"/usr/local/apache/vhosts/website.com/".

Expected result:
----------------
FOPEN should work with 10,000 VHOSTS if not more.

Actual result:
--------------
when fopen starts to run the whole page comes out blank right at the
fopen command.


------------------------------------------------------------------------


--
Edit this bug report at http://bugs.php.net/?id=37411&edit=1
  Reply With Quote


  sponsored links


Reply


Thread Tools
Display Modes




Copyright 2006 SmartyDevil.com - Dies Mies Jeschet Boenedoesef Douvema Enitemaus -
666