Mombu the Php Forum sponsored links

Go Back   Mombu the Php Forum > Php > #31050 : SOAP class will not parse WSDL file located on a secure HTTPS connection
User Name
Password
REGISTER NOW! Mark Forums Read

sponsored links


Reply
 
1 11th July 06:54
php-bugs@lists.php.net (samirshah_082005 at yahoo dot
External User
 
Posts: 1
Default #31050 : SOAP class will not parse WSDL file located on a secure HTTPS connection


ID: 31050
Comment by: samirshah_082005 at yahoo dot com
Reported By: dylanwoster at mac dot com
Status: No Feedback
Bug Type: SOAP related
Operating System: Mac OS X 10.3.6
PHP Version: 5.0.2
Assigned To: dmitry
New Comment:

I am getting the same error when creating soap client of a web service
with https. Did anyone find any solution?


Previous Comments:
------------------------------------------------------------------------

[2005-02-01 01:00:04] php-bugs at lists dot php dot net

No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".

------------------------------------------------------------------------

[2005-01-20 08:46:12] dmitry@php.net

I see no problems with latest CVS version on Linux, but I cannot test
this on MacOS X.

------------------------------------------------------------------------

[2004-12-10 05:22:21] dylanwoster at mac dot com

Description:
------------
The built in SOAP class for PHP5 will not parse a WSDL
file located on a secure HTTPS connection. The same WSDL
works fine on an identical build on a Linux machine and
any HTTP connections work fine.

Registered Streams: php, file, ftp, gopher, telnet,
dict, ldap, http, https, ftps, compress.zlib

'./configure' '--with-mysql=/Library/MySQL' '--with-
apxs2=/Library/Apache2/bin/apxs' '--prefix=/Library/
PHP5' '--with-mysqli=/Library/MySQL/bin/mysql_config'
'--with-libxml-dir=/usr/include/libxml2' '--with-curl=/
usr/local' '--with-curlwrappers' '--with-mcrypt=/usr/
local' '--with-java=/usr/bin/java' '--with-openssl' '--
with-zlib' '--with-gd' '--with-jpeg-dir=/usr/local' '--
with-png-dir=/usr/local' '--enable-xslt' '--with-xslt-
sablot' '--enable-soap' '--enable-sockets' '--enable-
ftp'

OpenSSL is version 0.9.7e

Reproduce code:
---------------
$client = new SoapClient(
"https://arcweb.esri.com/services/v2/Authentication.wsdl" );
echo( $client->getVersion( ) );

Expected result:
----------------
On the Linux machine I get the version of the ESRI web
services

Actual result:
--------------
Fatal error: Uncaught SoapFault exception: [WSDL] SOAP-
ERROR: Parsing WSDL: Couldn't load from 'https://
arcweb.esri.com/services/v2/Authentication.wsdl' in /
Users/dylanoster/Sites/www.maionline.com/site1/html/
soap.php:2 Stack trace: #0 {main} thrown in /Users/
dylanoster/Sites/www.maionline.com/site1/html/soap.php
on line 2


------------------------------------------------------------------------


--
Edit this bug report at http://bugs.php.net/?id=31050&edit=1
  Reply With Quote


  sponsored links


2 30th September 12:11
php-bugs@lists.php.net (youngad6 at gmail dot
External User
 
Posts: 1
Default #31050 : SOAP class will not parse WSDL file located on a secure HTTPS connection


ID: 31050
Comment by: youngad6 at gmail dot com
Reported By: dylanwoster at mac dot com
Status: No Feedback
Bug Type: SOAP related
Operating System: Mac OS X 10.3.6
PHP Version: 5.0.2
Assigned To: dmitry
New Comment:

Still a problem for PHP 5.2.1 running on OS X 10.4.8

../configure --prefix=/apache2/php --enable-soap --enable-memory-limit
--with-mysql=/usr/local/mysql --with-mysqli --with-zlib --with-xml
--with-ldap=/usr --enable-cli --with-zlib-dir=/usr --enable-exif
--enable-ftp --enable-mbstring --enable-mbregex --enable-dbx
--enable-sockets --with-iodbc=/usr --with-curl=/usr
--with-apxs2=/apache2/bin/apxs


Previous Comments:
------------------------------------------------------------------------

[2006-05-31 10:13:14] ykin at vertriebsunion dot de

I have the same problem here. It's all served by an actual xampp
installation on win2k servers.
The constructor is able to retrive the do***ent per http and local file
acess.
The https case procuses after a timeout minute following warning and
not shown followup errors:

Warning:
SoapClient::__construct(https://www.js.vertriebsunion.de/VuJournalService/Authentifizierung.asmx?WSDL)
[function.--construct]: failed to open stream

------------------------------------------------------------------------

[2006-01-09 07:52:19] samirshah_082005 at yahoo dot com

I am getting the same error when creating soap client of a web service
with https. Did anyone find any solution?

------------------------------------------------------------------------

[2005-02-01 01:00:04] php-bugs at lists dot php dot net

No feedback was provided for this bug for over a week, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".

------------------------------------------------------------------------

[2005-01-20 08:46:12] dmitry@php.net

I see no problems with latest CVS version on Linux, but I cannot test
this on MacOS X.

------------------------------------------------------------------------

[2004-12-10 05:22:21] dylanwoster at mac dot com

Description:
------------
The built in SOAP class for PHP5 will not parse a WSDL
file located on a secure HTTPS connection. The same WSDL
works fine on an identical build on a Linux machine and
any HTTP connections work fine.

Registered Streams: php, file, ftp, gopher, telnet,
dict, ldap, http, https, ftps, compress.zlib

'./configure' '--with-mysql=/Library/MySQL' '--with-
apxs2=/Library/Apache2/bin/apxs' '--prefix=/Library/
PHP5' '--with-mysqli=/Library/MySQL/bin/mysql_config'
'--with-libxml-dir=/usr/include/libxml2' '--with-curl=/
usr/local' '--with-curlwrappers' '--with-mcrypt=/usr/
local' '--with-java=/usr/bin/java' '--with-openssl' '--
with-zlib' '--with-gd' '--with-jpeg-dir=/usr/local' '--
with-png-dir=/usr/local' '--enable-xslt' '--with-xslt-
sablot' '--enable-soap' '--enable-sockets' '--enable-
ftp'

OpenSSL is version 0.9.7e

Reproduce code:
---------------
$client = new SoapClient(
"https://arcweb.esri.com/services/v2/Authentication.wsdl" );
echo( $client->getVersion( ) );

Expected result:
----------------
On the Linux machine I get the version of the ESRI web
services

Actual result:
--------------
Fatal error: Uncaught SoapFault exception: [WSDL] SOAP-
ERROR: Parsing WSDL: Couldn't load from 'https://
arcweb.esri.com/services/v2/Authentication.wsdl' in /
Users/dylanoster/Sites/www.maionline.com/site1/html/
soap.php:2 Stack trace: #0 {main} thrown in /Users/
dylanoster/Sites/www.maionline.com/site1/html/soap.php
on line 2


------------------------------------------------------------------------


--
Edit this bug report at http://bugs.php.net/?id=31050&edit=1
  Reply With Quote


  sponsored links


Reply


Thread Tools
Display Modes




Copyright 2006 SmartyDevil.com - Dies Mies Jeschet Boenedoesef Douvema Enitemaus -
666