Mombu the Programming Forum sponsored links

Go Back   Mombu the Programming Forum > Programming > Can't access 4.12 server
User Name
Password
REGISTER NOW! Mark Forums Read

sponsored links


Reply
 
1 8th August 05:55
nospam
External User
 
Posts: 1
Default Can't access 4.12 server


A client still has a 4.12 server and as explained below* after several
years of trouble free running something happened over the weekend and
now the server cannot be seen.

Using Client32 the Tree can be seen and the Name Context.
However when browsing for the Server it is not displayed under the
Context.

It is a single server installation and there is no other NDS on the
network.

I'm very rusty on all this now and the machine is a production server.


How do I get the server service back?


* Over the weekend an IT company did a migration of all users (Windows
2000 workstations) to a new ADS domain using something called Quest.
During this the company reported that the Netware server had lost its
volumes and the disk raid lights were showing orange. For some
unexplained reason they then ran a DSRepair.

Anyone know what this Quest is and are there tools now to migrate
Netware to an ADS?

All help gratefully received as I'm losing sleep over this.


--
AnthonyL
  Reply With Quote


  sponsored links


2 8th August 05:55
david gersic
External User
 
Posts: 1
Default Can't access 4.12 server


Sounds like SYS: is no longer mounted. The server is still advertising
its name and the Tree name via SAP, but it's not actually working.

Ok, that's interesting, but probably not relevant to the problem.

*This* is probably relevant. Sounds like the disk subsystem went
castors-up. That would dismount the SYS: volume. What's been done since then?

And the results of this were...?


--
| David Gersic http://www.zaccaria-pinball.com |
| Macho Law forbids me from admitting I'm wrong. |
| Email address is a spam trap. Visit the web site for contact info. |
  Reply With Quote
3 8th August 05:55
nospam
External User
 
Posts: 1
Default Can't access 4.12 server


Thanks for responding David. Responses in-line.


SYS: is loaded as are the other two volumes. In fact (apart from the
fact I haven't attached a tape drive) there are no errors that I can
see on the server console which comes with the prompt server_name:


I've done a google search for this and quoting from: http://www.whycore.co.uk/smartPortal/portal/cn/corenews/corenews;jsessionid=B78E78E2A726C9FE4326164EE0CA9D75
<quote>
AD Migration Suite.

The Quest Migration Suite for Active Directory is a solution for
planning and executing migration projects to Active Directory from
Windows NT, Novell NDS, or even Active Directory. This powerful
solution offers no interruption to your business workflow and offers four key components.
<endquote>

They were not supposed to touch the Novell server.


We have the problem that now exists. I am trying to get further
information but the client needs their server back on-line.


--
AnthonyL
  Reply With Quote
4 8th August 05:55
nospam
External User
 
Posts: 1
Default Can't access 4.12 server


Just to follow on I have just setup a Client32 to do a bindery only
and I can log on to the server.

So it seems to have got separated from the tree. Any idea what is the
best way to put it back remembering that it is single server?

Many thanks


--
AnthonyL
  Reply With Quote
5 8th August 05:55
david gersic
External User
 
Posts: 1
Default Can't access 4.12 server


You missed the point of the question. DSRepair has many options,
but you didn't specify which ones they used / selected. Nor did
you say what the results were from DSRepair (look in its log file
if they also don't know). Did it find any problems? Did it fix
anything? Were there any errors reported?

In DSRepair, there's an option on the main menu for Login and Log
File Configuration. If you go in there, can you log in using the
admin account and password?

Given what you've told me so far, that's good to know, but not especially
relevant. I'm trying to help you, but need more information in order to
do so. They're running an ancient version of NetWare, so their support
options are pretty limited. I haven't seen or touched a NetWare 4.x server
since 1999, so I'm going to have to ask more questions than if they
were running something current. Many of the major details are the same
in current versions, but many smaller details have changed from version
to version and service pack to service pack over the last 7 years.


--
| David Gersic http://www.zaccaria-pinball.com |
| Newspaper headline: Women's Movement Called More Broad-Based |
| Email address is a spam trap. Visit the web site for contact info. |
  Reply With Quote
6 8th August 05:55
david gersic
External User
 
Posts: 1
Default Can't access 4.12 server


Interesting. That seems to indicate that directory services is working,
since bindery emulation requires directory services.

Can't be "separated". If it were, it wouldn't be working at all.

--
| David Gersic http://www.zaccaria-pinball.com |
| Sooner or later, doesn't EVERYONE quit smoking? |
| Email address is a spam trap. Visit the web site for contact info. |
  Reply With Quote
7 19th August 04:26
nospam
External User
 
Posts: 1
Default Can't access 4.2 server (not 4.12)


Firstly sorry for any confusion but the server is the latest patch of
4.2 (don't know where 4.12 came from).

As far as I know the automatic option of DSREPAIR was run with lots of errors.

Wherever I have reached an option to login on the server I fail. I am using cn=admin.o=context.

Yes, fading memory is one of my problems.

There are 3 volumes and I there is nothing but Netware on SYS: so I
can afford to lose that readily. There is nothing complex about the
setup of the directories or users and it is no big deal to re-create
them. It's all on a RAID 5 so I can't disconnect a drive.

If it is safe just to delete the NDS and recreate manually then that
will work well for me.

Many thanks

--
AnthonyL
  Reply With Quote
8 19th August 04:26
david gersic
External User
 
Posts: 1
Default Can't access 4.2 server (not 4.12)


I don't recall what that menu choice is labled in that version, but it
often shows lots of errors. Most of them aren't, actually.

I don't think you have a DS problem, though that remains to be seen.
Let's stay away from dsrepair for now.

Try .admin.container instead. Or, possibly .cn=admin.o=container .


--
| David Gersic http://www.zaccaria-pinball.com |
| Cows in orbit: The herd shot around the world. |
| Email address is a spam trap. Visit the web site for contact info. |
  Reply With Quote
9 19th August 04:26
nospam
External User
 
Posts: 1
Default Can't access 4.2 server (not 4.12)


Just to close this off, removing the DS and creating a new one has
sorted the server. There is no doubt that the DS was trashed.

The login then worked as expected.

Restore of the arcserve created servdata.nds using Load Install
failed, as did the restore of the newly created DS (backup.nds). I
intend to retest on a test server ensuring the latest version of DS.


--
AnthonyL
  Reply With Quote
10 19th August 04:26
david gersic
External User
 
Posts: 1
Default Can't access 4.2 server (not 4.12)


servdata.nds is only a "skeleton" of the database and can only be used
to restore in a multi-server environment where you have other replicas
of the data to work with.


--
| David Gersic http://www.zaccaria-pinball.com |
| Real Newspaper Headline: EYE DROPS OFF SHELF |
| Email address is a spam trap. Visit the web site for contact info. |
  Reply With Quote
Reply


Thread Tools
Display Modes




Copyright 2006 SmartyDevil.com - Dies Mies Jeschet Boenedoesef Douvema Enitemaus -
666